[Newbies] Problems getting started with OpenGL in Squeak

Ken G. Brown kbrown at mac.com
Mon Aug 4 01:51:27 UTC 2008

At 4:53 PM -0700 7/31/08, beginners-request at lists.squeakfoundation.org apparently wrote:
>Date: Thu, 31 Jul 2008 16:53:42 -0700 (PDT)
>From: Nick Ager <nick.ager at gmail.com>
>Subject: Re: [Newbies] Problems getting started with OpenGL in Squeak
>To: beginners at lists.squeakfoundation.org
>Message-ID: <18765876.post at talk.nabble.com>
>Content-Type: text/plain; charset=us-ascii
>Hi Derek,
>thanks for the reply. I've inspected "SmalltalkImage current
>listLoadedModules" and "SmalltalkImage current listBuiltinModules" and there
>is no sign of "module:'Squeak3D'". I also checked my Croquet installation
>and again no sign of "module:'Squeak3D'" - however the Croquet image appears
>to have a different installation of OpenGL; there is no sign of Balloon3D*.
>Do I need a "Squeak3D.dll" module is so where would I find it? Google points
>me to http://wiki.squeak.org/squeak/2874, which is interesting but that
>particularly helpful.
>Are there two separate implementations of OpenGL in Squeak - one in Croquet
>and one in "standard" squeak.
>Derek O'Connell-2 wrote:
>> Try inspecting the following to confirm the module is present:
>> SmalltalkImage current listLoadedModules
>> if not then same on:
>> SmalltalkImage current listBuiltinModules
>> On Wed, Jul 30, 2008 at 2:25 PM, Nick Ager <nick.ager at gmail.com> wrote:
>>> Hi,
>>> I'd like to experiment with OpenGL in Squeak. I found the promisingly
>>> titled
>>> "Howto - Loading OpenGL in Squeak 3.9" from Jakub Kozisek
>>> (http://lists.squeakfoundation.org/pipermail/beginners/2006-November/001451.html)
>>> and followed the directions:
>>> * install FFI and Balloon3D from SqueakMap. (I used the Universe browser
>>> to
>>> install FFI version 3.9.1 and Balloon3D version 0.18.2)
>>> * install OpenGL-ckl.4.mcz from Monticello repository at
>>> http://www.squeaksource.com/OpenGL
>>> * apply change set from
>>> http://lists.squeakfoundation.org/pipermail/beginners/attachments/20061118/459ce649/OpenGLUpdate.1.obj
>>> * ensure squeak.ini contains: B3DXUsesOpenGL = 1
>>> * OpenGLMorph new openInWorld.
>>> Unfortunately the instructions resulted in the following error:
>>>>>> Error: Error a primitive has failed
>>> Examining the stack trace the error was in:
>>>  B3DPrimitiveRasterizerState>>primInitializeBuffers
>>> which reads:
>>>    B3DPrimitiveRasterizerState>>primInitializeBuffers
>>>        <primitive: 'b3dInitializeRasterizerState' module:'Squeak3D'>
>>>        ^self primitiveFailed
>>> I ran the shipped FFI tests and all tests passed.
>>> I'm running under windows using a VM from SqueakVM-Win32-3.10.6-bin.zip
>>> and
>>> an image sq3.9.1-7075dev08.07.1
>>> I downloaded Croquet which displayed it's 3D world successfully, but
>>> would
>>> prefer a minimal OpenGL installation. I tried the Croquet VM with my
> >> image,
>>> but got the same problem.
> >>
> >> Any ideas?
> >>
> >> Nick
> >> --

Not sure this will help in your case, but just for information, there are some plugin naming convention issues, the generated name does not always match the plugin name.

internal plugin B3DEnginePlugin generated as Squeak3D
internal plugin BalloonEnginePlugin generated as B2DPlugin
internal plugin BitBltSimulation generated as BitBltPlugin
internal plugin DSAPlugin generated as DSAPrims
internal plugin DeflatePlugin generated as ZipPlugin
internal plugin FFIPlugin generated as SqueakFFIPrims
internal plugin KlattSynthesizerPlugin generated as Klatt
internal plugin LargeIntegersPlugin generated as LargeIntegers

Ken G. Brown

More information about the Beginners mailing list