[Newbies] Flushing Squeak Cache

Dirk Leas dirkleas at gmail.com
Tue Jul 8 21:42:13 UTC 2008

I'm running latest Squeak on OS X. I in the beginning of Section 2 of the
laser game walk through and I forgot to add the class method to
GridDirection. I run the test cases including my new GridDirectionTestCase
and it of course fails as it doesn't know what the symbol is. I go back and
add it (browse it again after adding it just to make sure I added it), and I
get the same error in the Test Runner.

There have been several occasions where I add "something" (e.g. class,
method, instance variable, etc.), go back to do some rafactoring, and expect
the latest save to cascade through the VM so that my next test case runs the
latest code -- often it doesn't. I've seen this before in other environments
where the VM is cashing "stuff" and latest code isn't always getting run.


On Tue, Jul 8, 2008 at 5:34 PM, Matthew Fulmer <tapplek at gmail.com> wrote:

> On Tue, Jul 08, 2008 at 05:21:01PM -0400, Dirk Leas wrote:
> >    I'm enjoying my stroll through the laser game walk through, but find
> the
> >    VM caching scheme getting in the way with my test driven development
> (you
> >    know, hack w/t regard, fix typos, test again ;-)). How do I flush it?
> I have no idea what you are talking about. I don't know of any
> VM caching scheme. Could you describe what problem you
> encountered, and what you were doing?
> --
> Matthew Fulmer -- http://mtfulmer.wordpress.com/
> _______________________________________________
> Beginners mailing list
> Beginners at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/mailman/listinfo/beginners


Dirk Leas
South Orange, NJ

Ergonomic Tip of the Day: Hug your spouse and kids!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/beginners/attachments/20080708/d8efd344/attachment-0001.htm

More information about the Beginners mailing list