[Newbies] Flushing Squeak Cache

Matthew Fulmer tapplek at gmail.com
Tue Jul 8 22:04:19 UTC 2008

On Tue, Jul 08, 2008 at 05:42:13PM -0400, Dirk Leas wrote:
>    I'm running latest Squeak on OS X. I in the beginning of Section 2 of the
>    laser game walk through and I forgot to add the class method to
>    GridDirection. I run the test cases including my new GridDirectionTestCase
>    and it of course fails as it doesn't know what the symbol is. I go back
>    and add it (browse it again after adding it just to make sure I added it),
>    and I get the same error in the Test Runner.
>    There have been several occasions where I add "something" (e.g. class,
>    method, instance variable, etc.), go back to do some rafactoring, and
>    expect the latest save to cascade through the VM so that my next test case
>    runs the latest code -- often it doesn't. I've seen this before in other
>    environments where the VM is cashing "stuff" and latest code isn't always
>    getting run.

what is the error? The error message is saved as text in the
SqueakDebug.log file, which is next to the image file.

How are you adding the method? you just using the debugger or
browser to add the method, or are you doing something else?

Methods are compiled and added to the system as soon as you
press alt-s, so I think you may be seeing a different problem
than what you think you are seeing.

The error you would see in the case of a missing method is
"MessageNotUnderstood: GridDirection>>something"

are you getting this error instead?
"MessageNotUnderstood: UndefinedObject>>something"

That means you tried to send the message #something to the
object nil.

Matthew Fulmer -- http://mtfulmer.wordpress.com/

More information about the Beginners mailing list