[Newbies] Problems getting started with OpenGL in Squeak

Nick Ager nick.ager at gmail.com
Wed Jul 30 13:25:23 UTC 2008


I'd like to experiment with OpenGL in Squeak. I found the promisingly titled
"Howto - Loading OpenGL in Squeak 3.9" from Jakub Kozisek
and followed the directions:

* install FFI and Balloon3D from SqueakMap. (I used the Universe browser to
install FFI version 3.9.1 and Balloon3D version 0.18.2)
* install OpenGL-ckl.4.mcz from Monticello repository at
* apply change set from
* ensure squeak.ini contains: B3DXUsesOpenGL = 1
* OpenGLMorph new openInWorld.

Unfortunately the instructions resulted in the following error:

>>> Error: Error a primitive has failed

Examining the stack trace the error was in: 


which reads:
	<primitive: 'b3dInitializeRasterizerState' module:'Squeak3D'>
	^self primitiveFailed

I ran the shipped FFI tests and all tests passed. 
I'm running under windows using a VM from SqueakVM-Win32-3.10.6-bin.zip and
an image sq3.9.1-7075dev08.07.1

I downloaded Croquet which displayed it's 3D world successfully, but would
prefer a minimal OpenGL installation. I tried the Croquet VM with my image,
but got the same problem.

Any ideas?

View this message in context: http://www.nabble.com/Problems-getting-started-with-OpenGL-in-Squeak-tp18733147p18733147.html
Sent from the Squeak - Beginners mailing list archive at Nabble.com.

More information about the Beginners mailing list