[Newbies] squeak locks up on windows / help me debug it...

Cameron Sanders csanders.personal at functional-analyst.com
Sat Jan 10 05:47:51 UTC 2009

It was the code for the laser game tutorial that I was entering. And so far
everything (using Pharo 3.10) was behaving exactly as expected. (Except that
the refactoring menu items were available and used.)  I didn't define
stable. However, it seems like a development environment should wrap my 'do
it's and executions (even test runs) in safe environments (e.g. threads) so
that the world menu system continues to work even if I write an infinite
loop. And I suspect they are so that it does -- I imagine that there is a
defect in the base windowing system (Morphic?) and that no code is hearing
the mouse and keyboard events (noting that the menu on the window frame for
the VM is still responding, and the app repaints when necessary.) Mac people
snicker... and then we wonder if they coded it this way on purpose. 

I see that another Windows user has reported a lock-up on this forum just
last month. Perhaps I will back up and see if 3.9 is a better starting
point. 3.8? 

I will be glad to assist in making the development environment better (with
a first goal of a longer mean-time between lock-ups on Vista platforms),
because right now, those lock-ups are intolerable. I had an image up for 5
minutes last night when it locked up on me. Ironically, I was attempting to
save the image! Today, in this particular lock-up, I got distracted by email
or a phone call or something, and when I returned, Squeak was locked up.
Possibly I clicked something before I departed and forgot about it by the
time I came back. But basically, all inputs (except those that I mentioned)
ceased to function. 

By the way, I worked with VisualAge for Smalltalk back in '98 (for a year),
and it was very stable for me. I worked with VisualWorks last spring for a
couple of months, and it too didn't leave me panicky to save my code (to a
repository) every 5 minutes. It was quite solid, and intuitive. 

I attached gdb to the process, and of course when I caught it -- with only a
handful of samplings -- it was in the gc. (As expected.)

> The good news is your code isn't lost. You can roll it back from a clean
image from the .changes file. This is handy, but it is even better to use
something like Monticello.

Thanks, that is good news in general. In this case I can just grab the
tutorial code from a repository if I can't recover it.

I need to figure out how to get it to allow me to engage in simple browsing
and editing without lock-ups. Because without that... I just can't relax and

Thanks for the feedback,

More information about the Beginners mailing list