[Newbies] Squeak on FreeBSD/amd64 - Image Question(s)

Ralf Folkerts ralf.folkerts at gmx.de
Wed Jul 29 14:37:29 UTC 2009


I wanted to learn Smalltalk and wanted to go for Squeak. My OS is 
FreeBSD/amd64. I first wanted to install the FreeBSD Port; however, it 
stopped mentioning it was for i386 only and I was running amd64. So I 
tried to download the FreeBSD/i386 package from 
http://squeak.org/Download/ and installed according to the docs. 
However, that Squeak ran into a Trap 6; it seems it was unable to 
connect to X11 (I think it's because my X11-Libs are 64-bit only and so 
the 32-bit Squeak-X11-so might have run into trouble).

So I decided to do it the hard way and to compile for FreeBSD/amd64 on 
my own. I searched for the docs I found on squeak.org and squekvm.org, 
and tried to work as closely as possible to this doc: 
http://squeakvm.org/unix/. I checked the sources out using Subversion, 
configured and compiled. Ran into some Problems with missing 
Include-Directories in Makefiles, configured again by adding my local 
Include-Dirs, comoiled again, ran into an error that the 
ExtendedClipboard's Plugins Makefiles was missing my local Include, 
added that manually -- and finally had a seemingly working VM.

However, I now need "the Image" :-(

I found some docs on a "VMMmaker" which can be run by running squeak and 
passing it the name of and .image-File. So I did a "find . -name 
\*.image -print" in the platforms-Directory of the Sources I checked out 
- however, there is no .image-File there :-(

Another doc mentioned to download a "full" Image; however, I only found 
"basic" ones?

So, I tried to download


unzipped that into an empty Directory and ran "squeak 
Squeak3.10.2-7179-basic" - and squeak did start, well, it was 
complaining about missing sources, so I have to solve that.

However, in the "platforms/unix/misc/" Directory there are some Files 
plus Directions that I'd like to adhere, but beeing a complete noob have 
no idea how.

So, could somebody please hint me at how to get "the correct" Image for 
64bit FreebSD/amd64? Or is the Downloaded one OK? If it is, however, 
wouldn't I need a 3.10.5 Image instead of 3.10.2?

Would really be nice if somebody could help me - esp. because it seems 
to me that many of the Docs I found are a bit outdated and sent me into 
wrong directions I think...


More information about the Beginners mailing list