[Newbies] Can't load VMMaker classes

kmr1642 kmr1642 at yahoo.com
Fri Mar 27 22:28:09 UTC 2009

Michael van der Gulik-2 wrote:
> On 3/27/09, kmr1642 <kmr1642 at yahoo.com> wrote:
>> Hi all,
>> I'd like to look at the code for Interpreter
>> and ObjectMemory, in either Smalltalk or Slang,
>> but can't find any classes/files for them.
>> I noticed that the names appear in VMMaker comments
>> in the Package Universe but when I tried to load
>> any of the VMMakers, they all hung with a variety
>> of reasons. (I used a fresh 3.10.2-7179 image in win32).
>> Installing VMMaker using squeakMap also hung.
>> Does anyone know where the source for these classes
>> might be found for reading? Or a 1-click image that
>> contains VMMaker? (doesn't have to be current)
> Believe me, it's much easier downloading a prepared image:
> http://www.squeakvm.org/
> Go to "Unix" (even if you're using Windows or Mac) and there's an
> image available from that page that's set up ready to go.
> Gulik.
> -- 
> http://gulik.pbwiki.com/
> _______________________________________________
> Beginners mailing list
> Beginners at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/mailman/listinfo/beginners

On the Unix Squeak page you indicated
I downloaded  unix-3.10-4.vmm.tar.gz
and tried its image file on win32 vm.
It ran with no problem and has the classes 
I was lookin for, plus other VM goodies.


-Michael Ross
View this message in context: http://www.nabble.com/Can%27t-load-VMMaker-classes-tp22734495p22751059.html
Sent from the Squeak - Beginners mailing list archive at Nabble.com.

More information about the Beginners mailing list