[Newbies] Re: OOP Question - adding methods to core classes

Sean P. DeNigris sean at clipperadams.com
Wed Nov 3 14:43:33 UTC 2010

Ralph Johnson wrote:
> Yes, this is the Smalltalk way.
Thanks.  It was actually a lot of fun to chop away large sections of the

Ralph Johnson wrote:
> When you add a method to existing classes, you want to try to avoid name
> clashes.  Pick a name that nobody else is likely to use.   encodeForXmlRpc
> is a good name for that reason.
Yeah, I went down that little path, where I kept the "encode" name and then
thought, "hmm... not a good name for a method on a core class"

View this message in context: http://forum.world.st/OOP-Question-adding-methods-to-core-classes-tp3020788p3025474.html
Sent from the Squeak - Beginners mailing list archive at Nabble.com.

More information about the Beginners mailing list