[Newbies] Need help with figuring out how to incorporate SqueakSSL + WebClient into Etoys

Steve Thomas sthomas1 at gosargon.com
Mon Apr 18 12:18:24 UTC 2011

Thanks Levante,

I tried - Print it: WebClientServerTest buildSuite run::

and got an exception:

MessageNotUnderstood(Object)>>doesNotUnderstand: #sunitAnnounce:toResult:

My guess is, that as you suspected, I do not have the correct version of
Sunit.   Where do I find the correct version?

I tried saving the packages SUnit and SUnitGui, from my Seaside 3.0 image to
a local directory, but when I tried to load SUnit I got:

ClassDescription class(Object)>>doesNotUnderstand:
Receiver: ClassDescription

So my guess here is I am missing Traits (I can spell this but I don't fully
understand them, a pointer to some good documentation would be nice).

Thanks again for your help,

On Mon, Apr 18, 2011 at 6:23 AM, Levente Uzonyi <leves at elte.hu> wrote:

> On Sat, 16 Apr 2011, Steve Thomas wrote:
>  So I found Andreas's post on Installing SqueakSSL with Seaside
>> <
>> http://squeakingalong.wordpress.com/2010/08/07/using-squeakssl-with-seaside/
>> >and
>> figured I would try it in Etoys (realizing it may not work).
>> I tried:
>> (Installer ss)
>> project: 'SqueakSSL';
>> install: 'SqueakSSL-Core';
>> install: 'SqueakSSL-Tests';
>> project: 'WebClient';
>> install: 'WebClient-Core';
>> install: 'WebClient-Tests';
>> install: 'WebClient-Seaside'.
>> But Installer was not defined in Etoys.
>> I tried using the "SqueakMap Package Loader" in Etoys, but got a message
>> saying "The SqueakMap master server is running version 2.3 and the client
>> is
>> 2.0, You need to upgrade" I clicked yes, I got an exception.
>> So I tried to load the .mcz files in the order listed by dragging them
>> onto
>> the Etoys image and selecting "load version".  This worked fine
>> for SqueakSSL-Core, but when I tried to load SqueakSSL-Tests, I got an
>> exception (below), the key error (as far as I can tell) is
>> Receiver: Warning: This package depends on the following classes:
>>  TestCase.
>> So from some more searching it seems TestCase is defined in SUnit (makes
>> sense) but when I browse the SUnit in Etoys, I only see TestCaseDebugger
>> (ie: no Test Case).  So I went to SqueakSource and loaded the latest SUnit
>> package (SUnit-NialRoss.40.mcz, didn't bother with the GUI, for now, let
>> me
>> know if I should).  Once I load the new SUnit, SqueakSSL-Tests loads fine.
> I'm not sure this is the right SUnit version, but you'll see if it works or
> not.
>> I then was able to load WebClient-Core and WebClient-Tests.
>> Now, how do I run the tests?
> Print it: WebClientServerTest buildSuite run
> or load SUnitGUI (though I guess it won't be compatible with your image).
>  Also, is this the correct approach? (ie: did I load the correct things or
>> am
>> I missing something?)
> I think it is. Note that you'll probably face several compatibility
> problems. You'll find fixes for most of them in the WebClient-Pharo package
> on squeaksource.com.
> Levente
>> My end goal is to allow kids to post to Google Blogs from within Etoys.
>> Thanks,
>> Stephen
>>  _______________________________________________
> Beginners mailing list
> Beginners at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/mailman/listinfo/beginners
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/beginners/attachments/20110418/1d736a72/attachment.htm

More information about the Beginners mailing list