[Newbies] Save a class comment in Unix Squeak 4.5 leads to 'RemoteString past end of file'

David T. Lewis lewis at mail.msen.com
Fri Aug 1 12:26:46 UTC 2014

On Fri, Aug 01, 2014 at 09:26:10AM +0100, David Corking wrote:
> I can't save class comments. I get 'RemoteString past end of file'
> which seems to be a failed attempt to write to the changes file.
> Any attempt to use the class browser after that causes the same error message.
> I downloaded the All-in-One package, and updated the image, but still
> have the same error.
> SqueakDebug.log at https://gist.github.com/dcorking/37540a86c1d3623c2b7a
> I am using an x86-64 PC with 64-bit Fedora 20.  As far as I can tell I
> have the 32 bit OS libraries installed. (Is there a command to confirm
> that Squeak can find all the 32 bit libraries it needs?)
> What should my next troubleshooting step be?

Hi David,

I think this is due to a bug that exists in some Linux systems. Here is
a pointer to some earlier discussion:


We added a fix (*) for this in trunk, so if you can update your image to
the latest version, the problem will go away.

Otherwise, just edit WriteStream>>nextChunkPut: and add this to at the
end of the method:

  self flush. "workaround for clib runtime bug on some platforms, affecting initial class comment creation"


(*) Actually, it's not so much a fix as a workaround for the OS bug. But
it does make the problem go away for the common case of editing a new class

More information about the Beginners mailing list