[Newbies] Incomplete Seaside instruction on squeak.org?

lostgweilo lostgweilo at gmail.com
Sun Aug 16 15:50:20 UTC 2015

Hello all,

I need help to get Seaside up and running on Squeak.
I have Squeak running (Squeak5.0, latest update: #15113, Image format 6521
(32 bit))

I went to http://www.seaside.st/ and clicked "Squeak Smalltalk" in the right
This sent me me to http://squeak.org/projects/#seaside 
I clicked on "Quick Install" which opens a window with the following
  Installer squeaksource
      project: 'MetacelloRepository';
      install: 'ConfigurationOfSeaside3'.
  (Smalltalk at: #ConfigurationOfSeaside3) load.

I evaluated that, and it runs without error, but I don't know what to do
How do I start Seaside? Nothing is getting served on localhost, and I don't
know how to specify the adapter and the port or start any server. 
I tried to follow instructions from multiple different tutorials and they
all want me to bring up a kind of Seaside control panel UI that appears to
be Pharo specific and did not get loaded on Squeak (I can't find it in any
Or else, they refer to Kom server and Adapter classes that did not get
loaded either, and I don't know where to get them from.

I tried to load a Kom server package separately, and that did not seem to
help, I still don't have any subclass of WAServerAdaptor loaded. I have been
poking around for a few days now and I am getting nowhere.

I hope someone can help me.

View this message in context: http://forum.world.st/Incomplete-Seaside-instruction-on-squeak-org-tp4843294.html
Sent from the Squeak - Beginners mailing list archive at Nabble.com.

More information about the Beginners mailing list