[Newbies] Entering the caret (^) in Squeak on Linux

Marc Hanisch marc.hanisch at googlemail.com
Thu Oct 4 09:03:47 UTC 2018

Hi Christian,

I've configured my keyboard with 'deadkeys' (I need the caret for
Esperanto characters like ĝĥ), so I already tried "^ + Space", but it
justs displays a questionmark.
When I switch to 'nodeadkeys' I can enter the caret. So this is solved
for now ;-)

But I'm still wondering, why I can't type UTF8-characters? I thought
Squeak is UTF-8 aware?

Thanks and best regards,
Am Do., 4. Okt. 2018 um 10:38 Uhr schrieb Christian Kellermann
<ckeen at pestilenz.org>:
> * Marc Hanisch <marc.hanisch at googlemail.com> [181004 10:25]:
> > Hello,
> >
> > any ideas? I've tested the stable Squeak release on Ubuntu 18.04 and
> > Fedora 28 and I can't enter the caret on both systems...
> On some system (depending on your layout config) the caret is a
> dead  key, that is, it will not get displayed when pressed once,
> but hold as a modifier for entering keys like ấ (which can be
> produced with ^ + a). Try typing ^ + space and see whether the caret
> appears. If that get's too annoying try configuring a 'nodeadkeys'
> variant in your keyboard layout preferences on your linux system.
> Christian
> --
> May you be peaceful, may you live in safety, may you be free from
> suffering, and may you live with ease.
> _______________________________________________
> Beginners mailing list
> Beginners at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/mailman/listinfo/beginners

More information about the Beginners mailing list