[Newbies] can't run 32 bit squeak 5.2 on 64 bit OS (Debian 10)

Ralph Boland rpboland at gmail.com
Fri Jul 19 14:13:35 UTC 2019

I am able to run Squeak 5.2 (64 bit) on 64 bit Debian 10
but when I try to run Squeak 5.2 (32 bit) I get the following error:

~/Downloads/Squeak5.2-32/Squeak5.2-18229-32bit-201810190412-Linux$ squeak.sh

Using /home/rocky/Downloads/Squeak5.2-32/Squeak5.2-18229-32bit-201810190412-Linux/bin/squeak...
could not find display driver vm-display-X11; either:
  - check that /home/rocky/Downloads/Squeak5.2-32/Squeak5.2-18229-32bit-201810190412-Linux/bin//vm-display-X11.so
exists, or
  - use the '-plugins <path>' option to tell me where it is, or
  - remove DISPLAY from your environment.

My assumption is that some 32 bit libraries are missing but that's only a guess.
If my assumption is correct can anybody tell me what libraries I need?

I think it's a red herring but it is noteworthy that there is a double
slash ('//')
immediately before the 'vm-display-X11.so exists ... in the error message.
I assume this is just a typo by the person who created the error message.

I tried the -plugins advice but it didn't seem to work.  Perhaps I did it wrong.

When I ran Squeak 5.2 32 bit on  Debian 9 (32 bit) it ran fine.

Any advice on how to resolve this problem much appreciated.
I can provide any additional information requested.

Ralph Boland

More information about the Beginners mailing list