[Box-Admins] Re: [squeak-dev] cogspurlinuxht under daemontools

Chris Muller ma.chris.m at gmail.com
Wed Jul 15 16:17:34 UTC 2015

On Sat, Jul 11, 2015 at 4:30 PM, Eliot Miranda <eliot.miranda at gmail.com> wrote:
> Hi Chris,
>     I really know very little about this.  I don't understand the mechanism.  But I'm told that the limits file takes effect on login.  i.e. if the file is created while a user is logged in it won't take effect for that user until that user logs out and logs back in again and only applies to those sessions that logged in once the file had been created.  I /dont/ know whether su sets up a new session.  i should try that experiment.
> So perhaps you could have daemon tools run login or su to create a new session and see if the ht version can be run by daemontools in that session.  Presumably daemons launched at boot aren't in the right state.  (What an absurdity they've invented here).

Good suggestion to try, unfortunately it didn't work.  I tried logging
in as root to see if it would "initialize" that account to have those
permissions, then logging out and starting the daemon.  Same error.

For the sake of progress, I've switched to using the ITHB vm.

More information about the Box-Admins mailing list