[Box-Admins] [squeak-dev] Squeaksource.com is down

David T. Lewis lewis at mail.msen.com
Sat Dec 10 02:54:07 UTC 2016

On Mon, Dec 05, 2016 at 11:07:04PM -0500, David T. Lewis wrote:
> On Mon, Dec 05, 2016 at 10:08:40PM -0500, David T. Lewis wrote:
> > Moving to box-admins for a couple of technical follow ups.
> > 
> > On Mon, Dec 05, 2016 at 05:17:00PM +0100, Levente Uzonyi wrote:
> > > 
> > > I tried to, but the VM wouldn't respond to USR2.
> > 
> > I'm not sure what is wrong with the VNC access via SIGUSR2, but I cannot
> > get it working right now. I think it might be related to a net name resolver
> > problem, but I could not figure it out tonight. I fixed the immediate problem
> > of a WideString user name by downloading the image to fix the image, but VNC
> > access is still not working.
> > 
> Specifically, I think it might be the old "NetNameResolver localHostName" problem
> that we fixed back in about 2010 or so. The squeaksource.com image still has the
> old code, and it hangs up when I run the squeaksource.com image on my Ubuntu PC.
> Maybe that is happening on dan.box.squeak.org now too.
> But the VNC access was working before on dan.box.squeak.org, and now it does not
> work, so I do not know if something may have changed that affects name service
> lookup.

I have confirmed that "NetNameResolver localHostName" hangs in the old squeaksource.com
image, and works as expected in any newer image. The local host address on dan.box.squeak.org
#(104 130 170 38) IPV4, and the local host name is ''.

I expect that the VNC problem will go away whenever the squeaksource.com image is updated
to any version newer than circa 2011.


More information about the Box-Admins mailing list