we really need help

stéphane ducasse ducasse at iam.unibe.ch
Tue Oct 11 17:29:07 UTC 2005

On 10 oct. 05, at 19:24, Andreas Raab wrote:

> Stef,
> Just like with change sets (which would suffer from the same  
> ordering problem of #insetBy: vs. isRectangle) you can't just throw  
> all of these changes in the same pot and hope it'll work. You need  
> to be a bit more orderly than that.

I know!!!!!
But I understood that MC would solved this kind of problem. At least  
I tried.

> In this case, the solution is to make package version(s) which  
> *only* includes the method #isRectangle; then post a configuration  
> that ensures this package version is loaded; then commit the other  
> fixes. That's basically the same way you'd use change sets - first  
> make one that includes #isRectangle, then post the remaining changes.

Yes of course.
But again. I would like to see how we could get a real atomic load.

> There is simply no way by which MC could decide how to load these  
> methods in the proper order. Sometimes you do need to give a  
> helping hand when migrating a running system and that's one of the  
> places.

Yes. I'm really wondering how envy was doing since it was atomic.


> Cheers,
>   - Andreas
> stéphane ducasse wrote:
>> Hi all
>> We ***really*** need help. I start to be really exhausted. Here  
>> is  the problem:
>> Marcus introduced a fix to speed up morphic isRectangle instead  
>> of  isKindOf: in insetBy:
>> and collected some other fixes.
>> Now when we take a 6693 image
>>     - merge MC275
>>     - load scriptLoader-md.6.mcz
>>     - execute script 6
>> you end up after merging to an infinite loop because SmallInteger   
>> does not know isRectangle
>> (even thought isRectangle is defined on Object). This sounds like  
>> MC  loaded first the method
>> insetBy: and that the progress bar needs it and  
>> Object>>isRectangle  is not loaded yet.
>> So what can we do?
>> I tried to tweak a bit the script by loading first kernel-md.42.mcz
>> take a 6693 image
>>     - merge MC275
>>     - scriptloader-sd.8.mcz
>>     script 6
>>     - but now I get an error because Debugger does not know  
>> stepAt:in:
>> So I do not know what to do except ordering things by hand.
>> I lost really a lot of time and be completely unproductive.
>> So does anybody have any suggestion?
>> Stef

More information about the Packages mailing list