[Seaside] Problems with HTTP basic authentication in 2.5a

Bany, Michel mbany at cincom.com
Sat May 8 19:07:54 CEST 2004

I added the method below and it worked for me.
Let me know if it corrects your problem.

	| root |
	root := super createRoot.
	root addDecoration: (WABasicAuthentication new authenticator: self).
	^ root

-----Original Message-----
From: seaside-bounces at lists.squeakfoundation.org
[mailto:seaside-bounces at lists.squeakfoundation.org]On Behalf Of C. David
Sent: Saturday, May 08, 2004 6:51 PM
To: The Squeak Enterprise Aubergines Server - general discussion.
Subject: [Seaside] Problems with HTTP basic authentication in 2.5a

I'm having problems with authenticateWith:during: in a task.  A very 
simple example is attached.  The link's callback never gets invoked.  
I'm working under Squeak 3.6 final in Linux.  Similar code worked under 
2.3 (although the method name was different and I think that it took an 
authentication block).  Any ideas?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/seaside/attachments/20040508/d1466b15/attachment.htm

More information about the Seaside mailing list