[Seaside] Component confusion

Jason Johnson jbjohns at libsource.com
Wed Aug 2 16:13:38 UTC 2006

Hello all,
I have just started using seaside, and I must say I am very impressed.
I have been able to fix all the problems I have ran into so far but now
I tried to make a new component and there seems to be something wrong
with it.  I am confused because it seems to me like any other component
(im using the Store example as a reference).  The message I get is
"Error. Components not found while processing callbacks:#(a WANavBar)".
What my component is trying to do is be the main navagation component
for a site I will eventually build.  It is a very simple class at the
moment.  It inherits from WAComponent and it has two instance variables:
items (the list items) and activeItem.  Here is the renderOn: method:
renderContentOn: html
            html divNamed: 'navcontainer' with: [
                        html cssId: 'navlist'; unorderedList: [
                                   items do: [:item| 
                                               (item = activeItem)
ifTrue: [ html cssId: 'active'].
                                               html listItem: [
anchorWithAction: [self activeItem: item ] text: item
As you can see, all I'm trying to do is make a CSS aware navagation so
that the designer can just do his thing with CSS without having to
figure out how it gets made.  I want any part of the site to use this.
I tried it in another test application where it does:
navBar := WANavBar new.
navBar items: #('Item one' 'Item two').
navBar activeItem: 'Item one'.
When I click on either item I get the above error.
Thanks very much for your help,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/seaside/attachments/20060802/8794fa78/attachment.htm

More information about the Seaside mailing list