[Seaside] Pier does not install seaside app on OSX

Lukas Renggli renggli at gmail.com
Mon Aug 14 07:32:08 UTC 2006

Hi Bakki,

> I had sent this msg to the Pier list but see no traffic on that list.
> So I am posting it here and hoping it won't be considered too
> offtopic.

sorry, I must have missed your question over at the Pier mailing list.
It's quite calm over there at the moment, but that's not always like

> I had installed Seaside per the tutorial but I used the new seaside
> installer again to pull in scriptaculous etc. I wasn't sure if this
> was kosher but I assumed that the installer might be smart enough to
> figure out already installed components.  But the Magritte also asked
> if it was ok install a newer Seaside2?

Yes, Magritte/Pier have its own installer and they load exactly the
Seaside/Scriptaculous versions I've deployed them with. In this case
this is an older version, but actually it shouldn't matter. The
installers are simply there to get you a working image, from there you
can easily update using Monticello.

> On Linux every thing worked just fine but on OSX, Pier (1.0.5-alpha)
> did not ask about config options such as base url being /seaside/pier
> etc. So Pier does not work and does not appear in seaside/config
> either.

Very strange, I expected it to be the other way round. I am developing
on OS X and I just tried to load it into Squeak3.9g-7054 and it worked
fine for me.

> Can some one explain if I am doing something wrong, or point me in the
> right direction to configure Pier. Thank you very much.

Try evaluating "PRPierFrame initialize".


Lukas Renggli

More information about the Seaside mailing list