[Seaside] Seaside Integrated Image and SqueakMap

Nevin Pratt nevin at bountifulbaby.com
Tue Feb 7 16:58:29 CET 2006

goran at krampe.se wrote:

>Hi Nevin!
>Nevin Pratt <nevin at bountifulbaby.com> wrote:
>>Anybody else have trouble opening a SqueakMap Package Loader browser 
>>from the Seaside 2.5 Integrated Image (image downloaded from 
>>I'm seeing numerous problems, on both Mac OS X as well as Windows XP.
>I just tried it and it worked fine for me (on XP). I guess you have an
>"old" sm directory in your working directory with a map in it that is
>already updated to SM 2.1. Best solution is to run this doit to force an
>	SMSqueakMap bootStrap
>...or you can delete all *.sgz files from the sm directory (no need to
>delete the whole directory - that would also erase the package cache).
>regards, Göran

Thanks, Göran.  Problem solved, however....

...when I first tried 'SMSqueakMap bootStrap', it failed on an error 
(attempt to index a non-existent element on ByteString-- didn't copy the 
stack though, so couldn't tell you what else).

So, I then quit the image without saving (to try to keep the image 
pristine), then deleted all the *.sgz files as you suggested.  Then I 
relaunched the image, selected "open...SqueakMap Package Loader", and it 
opened just fine.

So, problem solved.

Incidentally, my Squeak 3.8 installation was a pristine install direct 
from squeak.org.  So, if somebody downloads squeak from there, then goes 
to seaside.st and gets the Seaside integrated image, they will have this 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://liststest.squeakfoundation.org/pipermail/seaside/attachments/20060207/dec4a0e7/attachment.html

More information about the Seaside mailing list