[Seaside] WeakArray problems (I think)

Adrian Lienhard adi at netstyle.ch
Tue May 23 06:44:17 UTC 2006

Is this an known problem of the VM? I couldn't find  a bug report on  
Mantis for this, so it would be good if you could add one with some  
more information (VM version, OS).


On May 22, 2006, at 18:18 , Richard Huxton wrote:

> Dmitry Dorofeev wrote:
>> Hi,
>> I expirienced similar problems with CPU eating at 100% (UNIX top  
>> command output)
>> Image did not respond to socket requests at all. I sow it on  
>> FreeBSD quite
>> frequently and on Linux time to time. I decided that it might  
>> happen becouse
>> image takes all memory I left it to have with -memory switch to  
>> squeak command.
>> To stop it I run a daily Seaside clean up (I think the same as per  
>> link 'Clear caches'
>> on /seaside/config page). Hope that helps me, but not sure as it  
>> is only a week with this feature.
>> I run squeak as follows:
>> squeak -nodisplay -nosound -notimer -memory 512m esol.image
> Thanks Dmitry!
> Defining a memory setting seems to do it. That'll buy me enough  
> time to ensure my code changes are safe - I can rebuild a fresh  
> image then.
>> without memory limit it is not stable at all (seems a problem  
>> above 1Gb)
> Useful pointer.
> Thanks very much.
> -- 
>   Richard Huxton
>   Archonet Ltd
> _______________________________________________
> Seaside mailing list
> Seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

More information about the Seaside mailing list