[Seaside] Re: WAApplication isDeployed vs. deploymentMode

Philippe Marschall philippe.marschall at gmail.com
Tue Oct 17 15:53:37 UTC 2006

2006/10/16, Yanni Chiu <yanni at rogers.com>:
> Philippe Marschall wrote:
> > 2006/10/16, Bany, Michel <mbany at cincom.com>:
> >> Yes, I am the one who invented #isDeployed and it was my original
> >> intention to have the concepts independent. I suggested this idea at
> >> one of my customers where they wanted to make sure that no one would
> >> try urls like /seaside/counter in the deployed system but where
> >> /seaside/config would have the toolbar.
> >
> > Why not just remove them in the build process that makes the deployment
> > images?
> IMHO, that just hides the underlying problem in
> the build process.

I still don't see the point. Why do you want a counter in you deployed
application? Why do you want the dev toolbar in the config application
of the . Why can't your build system take care of that?

> They are independent concepts, but one of them is
> poorly named - probably the one that came second.
> Showing/hiding the toolbar is only one aspect of
> deployment mode. Maybe #isDeployed should have been
> #showToolbar.

No. #deploymentMode should be named renamed to #showToolbar.
The rest should be specific to your build system.


More information about the Seaside mailing list