[Seaside] Netstat -l

Chris Cunnington cunnington at sympatico.ca
Tue Sep 5 15:27:33 UTC 2006

Hi All,

I have an iBook. It runs Fedora Core 5. I install Squeak and Seaside, so it
listens automatically on port 8080. I can see this when I type "netstat -l |
grep webcache" Webcache is what the firewall gui app insists on calling port
8080. I can walk across the street to the University of Toronto library and
type in http://(DHCP generated IP here):8080/seaside/config and get the
login panel that takes me to my config page, and then to Scriptaculous.

I have a Red Hat Enterprise Server. I start Squeak "squeak -vm display=none
Squeak3.8[...]&" and it runs. I can see so when I type the "top" command. I
start Seaside "squeak -vm display=none Seaside2.6.image&", and again "top"
tells me it's running. I type "netstat -l | grep LISTEN", and I don't see
any port 8080. If I cross the street to the library and enter http://[my
static IP]:8080/seaside/config, then nothing happens.

It's odd what I can do with an iBook, I cannot do with an actual RHES.
Seaside is not listening on port 8080, for some reason.

To troubleshoot this problem I have tried opening the permissions for the
changes files for both Seaside and Squeak. I've tried the "-headless" flag
instead of "-vm display=none" (though I understand from the Squeak man page,
that I'm not supposed to do that because it's deprecated.) The RHES people
providing support are of the opinion that the problem is with the
application, not the RHES. Since Seaside is not listening on port 8080, I
believe them. 

I've considered learning how to add a startup script saying WAKom
startOn:8080, but that shouldn't be required if I've used Seaside once on
localhost to see webpages. Persistence means it will start in the state it
was left. 

How do I get Seaside in a server to listen on port 8080?

Chris Cunnington

More information about the Seaside mailing list