[Seaside] seaside Image running but UI frozen - story to unfreeze UI

Brad Fuller brad at sonaural.com
Fri Apr 13 15:26:21 UTC 2007

Philippe Marschall wrote:
> 2007/4/13, Brad Fuller <brad at sonaural.com>:
>> Situation I'd like to get your input on, and if you've ever seen this
>> before and possibly the best way to fix it.
>> Running 3.9 final with Seaside 2.7a and pier-seaside-lr.143. For some
>> reason the image UI froze - no input from vnc. top showed that the
>> squeak process wasn't excessive (didn't even see it in top) and from the
>> browser, everything was working fine. So, I figured that it was
>> something to do with the interface to the image -- e.g. vnc.
>> I went to the image and pressed Alt-.  didn't do anything. In the web
>> browser, I went to /seaside/tools/vnc and noticed that UI Process was
>> suspended. So I clicked the button, and checking the image, a couple of
>> windows that I had clicked on before came to the front. But, I still
>> didn't have access to the image via vnc. I press Alt-. again and, in the
>> web browser, the UI Process button showed that it was suspended again. I
>> once again clicked the button to un-suspend it and the interface to the
>> image was then accessible and all is (seemingly) well.
>> Ever see this?
> Yes quite often on some configurations (ask Nik Lutz). You can also
> use the screenshot application to resume the UI process. Sometimes it
> takes several suspend - resume cycles to work.
Good to know about the screenshot tool. I thought that was just a 
"screenshot". I didn't know it interacted with the image. Probably 
should change it's name to something more descriptive, like: "Squeak 
Interface". Even "Surf's Up" would be better ;-)

More information about the Seaside mailing list