[Seaside] upgrading methods

Brad Fuller brad at sonaural.com
Fri Feb 23 00:05:19 UTC 2007

Brad Fuller wrote:
> Brad Fuller wrote:
>> Lukas Renggli wrote:
>>>> >     WAComponent allSubclassesDo: [ :each | each initialize ].
>>>> >     WADispatcher resetAll.
>>> After doing this you need to stop and restart the server, so that it
>>> catches the new dispatcher.
>>>> UPDATE: Twice I stopped WAKom and restarted. The 3rd time, I stopped 
>>>> it,
>>>>   waited, and restarted and Seaside came up. Don't know if it was a
>>>> browser cache problem or what.
>>>> But, I don't have my Pier app. And, I want my Pier app!
>>> Excellent, now re-initialize Pier:
>>>     PRPierFrame initialize.
>>> Answer: yes (create an entry point) - no (create a new kernel) - a
>>> Kernel (select your old kernel) - accept (suggested entry point) - ok
>>> (try in the web browser).
>> Ok, another problem. I upgraded per your advice for the order. I saved 
>> as new version just so I could get back to where I was.
>> Seaside ran fine when updating. No problem.
>> But, when I run the new version I rcv from the browser:
>> ======
>>  Internal Error
>> MessageNotUnderstood: WAStandardFiles>>urlOf:
>> [] in WAStandardFiles(WAFileLibrary)>>updateRoot: {[:each | (each 
>> endsWith: #Js) ifTrue: [aHtmlRoot javascript url: (sel...]}
>> Array(SequenceableCollection)>>do:
>> WAStandardFiles(WAFileLibrary)>>updateRoot:
>> WAStandardFiles>>updateRoot:
>> [] in WAApplication>>updateRoot: {[:each | each default updateRoot: 
>> anHtmlRoot]}
>> OrderedCollection>>do:
>> WAApplication>>updateRoot:
>> WASession>>updateRoot:
>> WARender>>buildDocRoot
>> WARender>>buildResponse
>> [] in WARender>>render {[:u | url := u. self buildResponse]}
>> [] in WASession>>respond: {[:cc | url := self 
>> actionUrlForContinuation: cc. response := responseBlock...]}
>> ResponseContinuation class(Continuation class)>>currentDo:
>> WASession>>respond:
>> WARender>>render
>> [] in WARender>>go {[self render]}
>> BlockContext>>on:do:
>> WARender>>withRenderNowHandler:
>> [] in WARender>>go {[self withRenderNowHandler: [self render]. self 
>> shouldRedirect ifTrue: ...]}
>> BlockContext>>on:do:
>> ======
>> If I: WADispatcher resetAll
>> I rcv DNU: WAFileHandler: #basePath
>> WAFileHandler>>registerAsHandler: aString sends the message:
>>   handler := self new basePath: aString.
>> aString is: 'files'
>> WAFileHandler is trying to initialize, but there is no #basePath
>> So, I did something wrong during updating.
>> Any hints????
> Luckily I saved the image in increments. I went one back and it seems to 
> work.
> What I merged for the last image version, that didn't work, was
> Pier-Magma
> rsrss
> Pier-Blog
> And, I also tried to merge FileLibrary, in this last version, but I 
> could never get it to merge. When I pressed the Merge button in the 
> Merge Dialog box, it just did nothing.
> So, could any of these packages be the cause of the above trace?

(I know I keep replying to my own messages, but I think logging this is 
good for others. )

Ok, I found another problem. The version that I thought worked does not. 
It bails on any updates to Pier pages (removing them, saving them.) So, 
I went another version back. This version seems to work (HA! Famous Last 
Words!) I've added pages, removed them, moved them, etc... so at least 
that works.

To recap, this version has Seaside, Pier and Magritte from SqueakMap
Then, I upgraded in stages.

What this version does not have is:
Upgraded Magritte
Upgraded Pier

What this version has is:
Latest Seaside (2,7a1-mb.203)
Latest Scriptaculouse (lr-171)
Latest Seaside Installer

(no other Seaside packages)

BTW, this is all on v3.9 final

Does this not point to a problem up dating Pier and/or Magritte?. That's 
my first questions.

Should I not Merge but instead Load this packages? Or, would that really 
make a difference? That's my second, followup question.

Maybe the following is a problem: I do not have a selection "Static File 
Library" under the seaside/config  "Add entry point" - even though I 
have WAFileLibrary and it's class comment indicates I should have this 
My third question: Why do I not have a selection called: "Static file 
Library" in "Add entry point" dropdown? Is the class comment wrong?

brad fuller
  +1 (408) 799-6124

More information about the Seaside mailing list