[Seaside] [offtopic] LDAPLayer in Seaside

Stephen sdw2 at shineonline.co.nz
Tue Feb 27 02:38:30 UTC 2007

Hi All,

I'm trying to get LDAPLayer working for a Seaside app, otherwise I'll
have to write in Java! By way of explanation, I tried emailing
ragnar at linalco.com but that address gets bounced and so I'm hoping that
someone else on the list has used LDAPLayer and can give me a hand, or, 
knows where best to post a request for help on LDAPLayer.

Here is what I get in the *Debugger window title*:
LDAPException: invalid tag - make sure class is in identifyIncomingElements

*Program call*:
I'm trying to connect to a Linux server running openldap. I went into
the class methods of LDAPTest and set port, password, hostname, bindDN,
and baseDN.
I put the following two lines in a Workspace window and ran in debug...
ld := LDAPTest new.
ld connect.

Squeak is running on my Mac OS X 10.4.8 machine, I used a Squeak 3.7
image downloaded from the Seaside site. I also tried LDAPLayer on Squeak
on Windows and it failed although I think from memory, the error was
possibly different. I've also tried a different LDAP server, an OS X
Open Directory server but that didn't make an difference.
LDAPLayer was downloaded from Squeak Map - latest version.

*Where is it falling over:*
I traced the code to this area which is inside Socket>>sendData
        count := self primSocket: socketHandle
            sendData: aStringOrByteArray
            startIndex: bytesSent + 1
            count: (bytesToSend - bytesSent min: 5000).

I'd be really grateful to be able to do this project (and other upcoming
LDAP projects) in Seaside/Smalltalk.

Thank you

More information about the Seaside mailing list