[Seaside] small seaside image - not working on seasidehosting

Lukas Renggli renggli at gmail.com
Fri May 18 13:39:33 UTC 2007

> On the seasidehosting site, however that same trick doesn't work.  In fact
> when I start the image something on the system is creating a
> SqueakV3.sources.  *directory* ... that appears to be just a symboilic link
> back to my main directory.

Why do you think it points to your main-directory? When I do an "ls
-l" in your directory I get:

    46 2007-05-18 14:46 SqueakV39.sources ->
    45 2007-05-18 14:46 SqueakV3.sources ->
    4430306 2007-05-18 14:46 squeak-web-118.changes
    26888812 2007-05-18 14:00 squeak-web-118.image

A "cat SqueakV3.changes" shows the sources. We create those links
link, so that you don't have to upload them yourself and to avoid
having 250 of identical source files wasting harddisk space. Btw, in
the preferences you can also tell you Squeak image not to complain
about missing changes and sources files.

> In the meantime I have uploaded another "bloat" image that *is* working
> (squeak-web-118.image  (27meg !)

We currently have a quota of 256 MB of RAM and 128 MB harddisc space per user.

> When I run anything in that file however,  like Pier, then stop and restart
> the image, nothing gets saved.  I tried copying the running image to another
> image, then runnig the copy but that didn't work.

That's how Squeak works. Evaluate something like "SmalltalkImage
current saveSnapshot" to save it. If I remember correctly
WAVersionUploader has a button that does exactly this. The Pier Unix
Security plugin also provides a user interface to save the image.


Lukas Renggli

More information about the seaside mailing list