[Seaside] Seaside for Swazoo woes Was: Long submit problems with IE

Janko Mivšek janko.mivsek at eranova.si
Fri Nov 16 12:36:38 UTC 2007

Hi Carl,

As Boris said be sure that you loaded Swazoo 1.0 (you did if you loaded 
SeasideForSwazoo as a parcel), then try to do from workspace something 
like this:

1. SwazooServer stop.
2. Inspect SwazooServer singleton sites and in your site inspect
3. set host:ip:port: combination accordingly. For instance:
     host: 'localhost'
     ip: 'localhost'
     port: 8888
4. SwazooServer start.
5. open http://localhost:8888/... (whatever Seaside expects here)

There is something in current SeasideForSwazoo which setup defualt 
SeasideSite differently, so above method is most secure that everything 
will start as expected.

Best regards

Boris Popov wrote:
> What version of swazoo did you load as prerequisite? I think only 1.0ish 
> works with it. Also, try your hostname instead of localhost, swazoo is 
> finicky a bit as far as names, but I'm not sure there, its been a while 
> since I tried a base install.
> Cheers!
> -Boris
> (Sent from a BlackBerry)
> ----- Original Message -----
> From: seaside-bounces at lists.squeakfoundation.org 
> <seaside-bounces at lists.squeakfoundation.org>
> To: vw-dev at parcplace.net <vw-dev at parcplace.net>; 
> seaside at lists.squeakfoundation.org <seaside at lists.squeakfoundation.org>
> Sent: Thu Nov 15 19:45:19 2007
> Subject: [Seaside] Seaside for Swazoo woes Was: Long submit problems with IE
> Okay, I decided to try Seaside for Swazoo.  I've tried it under VW 7.4.1 and
> VW 7.5.  I've loaded it from the installed files and from the public store.
> No matter what I do all I ever get after install is "Internet Explorer
> cannot display the webpage".
> Am I missing something?  Is there a control panel?  Do I need to execute
> some expression to start the server?
> Thanks in advance,
> -Carl Gundel
> http://www.runbasic.com
>  >
>  > Yes, I'll give it a try.  I just feel a bit out of my depth when it comes
>  > to web stuff.  I'll probably learn something useful though.  ;-)
>  >
>  > -Carl
>  >
>  >> But you need to know what the problem is. If it works on swazoo, at 
> least
>  >> you can compare the two and find the difference, no?
>  >>
>  >>> I'll try it, but even if it fixes the problem I cannot use it for my
>  >>> release.  That would be a huge disruption considering I've just gone
>  >>> through
>  >>> 2 months and 5 beta releases on Web Toolkit.  I'll be happy to consider
>  >>> another web server for a followup in a few months, but right now I just
>  >>> need
>  >>> a fix or a clever workaround.  :-/
>  >>>
>  >>> -Carl Gundel
>  >>> http://www.runbasic.com

Janko Mivšek
Smalltalk Web Application Server

More information about the seaside mailing list