[Seaside] PlotKit in VW 7.4.1

Michel Bany michel.bany at gmail.com
Tue Nov 20 22:40:30 UTC 2007

It is not a matter of what VW version. Seaside-HTML5 does not work  
with this version of SeasideForSwazoo.

Instead, try this combination:
Swazoo 1.0
SeasideForSwazoo 2.7b1.23.0
SeasidePlotKit 1.28

This should work because 2.7b1 has enough HTML5 support for PlotKit  
(it has #canvas) while 2.8 does not have any HTML5 at all.

If you really really need Seaside 2.8, then you will also need some  
patience until someone or I create a VW port of HTML5 that works with  
SeasideForSwazoo 2.8a1


On Nov 20, 2007, at 8:18 PM, Andres Fortier wrote:

> Hi list, me again :(. I'm using VW 7.4.1 and, as Boris suggested, I  
> loaded the following packages from the public repository to run  
> seaside:
> Swazoo 1.0
> SeasideForSwazoo 2.8a1.488.0
> these packages work ok. Now I'm trying to make PlotKit work; it  
> loads ok from the repository, but when I try the examples get a  
> #dnu for the #canvas message. A couple of days ago there was a post  
> on this issue and the proposed solution was to load HTML5. I tried  
> that, but I get a load-time errors of definitions that can't be  
> loaded because their superclasses are not present in the image  
> (most of them related to seaside-opentalk packages). I tried  
> different versions of the HTML5 related packages and none of them  
> seems to work. Has anybody successfully loaded HTML5 in a 7.4.1  
> image? If not, is there another graph plotting fwk that can be used  
> straightforward with seaside?
> Thanks in advance,
>                   Andrés
> _______________________________________________
> seaside mailing list
> seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

More information about the seaside mailing list