[Seaside] [BUG] WAUrl>>scheme:

Boris Popov boris at deepcovelabs.com
Thu Oct 18 18:18:33 UTC 2007

Michel, Philippe,

Ah, so setting server protocol to #http is perfectly fine in Squeak.
It'd be much appreciated if we could keep the fix (of any sorts) in
place for us VisualWorks folk who happen to have symbols stuck there

a) they used to work, so some apps may have been coded that way
b) WAGlobalConfiguration(defaults)>>serverProtocol ^ #http



DeepCove Labs Ltd.
4th floor 595 Howe Street
Vancouver, Canada V6C 2T5

boris at deepcovelabs.com


This email is intended only for the persons named in the message
header. Unless otherwise indicated, it contains information that is
private and confidential. If you have received it in error, please
notify the sender and delete the entire message including any

Thank you.

> -----Original Message-----
> From: seaside-bounces at lists.squeakfoundation.org [mailto:seaside-
> bounces at lists.squeakfoundation.org] On Behalf Of Michel Bany
> Sent: Thursday, October 18, 2007 11:15 AM
> To: Seaside - general discussion
> Subject: Re: [Seaside] [BUG] WAUrl>>scheme:
> On Oct 18, 2007, at 8:07 PM, Boris Popov wrote:
> > Michel,
> >
> > I'm not quite clear how they pass in Squeak, because encodeServerOn:
> > does a simple comparison (scheme = 'http') which should fail when
> > scheme
> > is #http?
> >
> Oh, I forgot to mention that #foo = 'foo' answers true inSqueak.
> _______________________________________________
> seaside mailing list
> seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

More information about the seaside mailing list