[Seaside] how to create new seaside entry point for webapp in topaz (WAS scriptaculous in updateRoot?)

Chris Dawson xrdawson at gmail.com
Wed Jun 11 17:14:00 UTC 2008


Thanks for the response.  So, being new to GemStone and Seaside, what is the
correct way to install a new application within topaz?  I've done this
within the Seaside config webgui plenty of times and am a little lost as to
where and what I should do within topaz.  I ran printit on WADispatcher
default and see this:

topaz 1> printit
WADispatcher default
a WADispatcher
  parent          nil
  name            seaside
  entryPoints     a Dictionary
  defaultName     browse
  lastUpdate      a TimeStamp
  version         55

I'm now browsing the methods available within WADispatcher and see
#register:.  This only takes a name, however, so do I instantiate an
instance of my webapp, and then what?


On Wed, Jun 11, 2008 at 9:41 AM, Dale Henrichs <dale.henrichs at gemstone.com>

> Chris Dawson wrote:
>  I did not, and that fixed it.  Thanks!
>> Now I'm trying to figure out how I can add this programmatically rather
>> than in the configuration editor.  It looks like the method #addLibrary:
>> in WAApplication is what I want, but how do I get access to the
>> WAApplication object in my session?  I want to do this from topaz under
>> GemStone, so I suppose I need to first find the WAKom object, then get
>> the first instance, then...
>> Chris
>> On Wed, Jun 11, 2008 at 2:59 AM, John Thornborrow < john at pinesoft.co.uk
>> <mailto:john at pinesoft.co.uk> > wrote:
>> Hi,
>> In your /seaside/config for your application, have you still got the
>> file library SULibrary loaded? (sample screen shot:
>> http://img71.imageshack.us/img71/7861/screenshotyr5.png
>> <http://img71.imageshack.us/img71/7861/screenshotyr5.png> )
>> HTH,
>> John.
> Chris,
> There is no WAKom in GemStone.
> For programmatic access you can get to an application by starting with
> 'WADispatcher default' and follow the 'entryPoints' to your target
> application.
> If you do happen to have access to your WASession, then sending
> #application to the session should do the trick.
> Dale
> _______________________________________________
> seaside mailing list
> seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/seaside/attachments/20080611/e289f184/attachment.htm

More information about the seaside mailing list