[Seaside] Re: Squeak won't respond

xyz 42 xyzz42 at gmail.com
Sun Oct 12 17:07:41 UTC 2008

On Sun, Oct 12, 2008 at 8:21 PM, xyz 42 <xyzz42 at gmail.com> wrote:
> On Sun, Oct 12, 2008 at 8:01 PM, Markus Fritsche
> <fritsche.markus at gmx.net> wrote:
>> xyz 42 schrieb:
>>> I am using Squeak 3.9 and Seaside 2.8.3 (I think).  I have a debug log
>>> as well.  I am not sure when the log was created.  When I got this
>>> problem, I tried to restore my changes first.  So I am not sure if the
>>> log was created when I tried to restore my changes or when I had this
>>> problem.
>> Your log says that the last failed action was to try to remove method
>> "initialize" of ErAdminComponent (which is nil). I am not sure if that
>> log is connected to your problem.
> Yes, when I restored my changes, I was missing ErAdminComponent (I am
> not sure I restored the changes properly.  My changes file is around
> 11 MB and contains code dating 2001).  Also, some classes had their
> parent changed as follows -
> AnObsoleteErMenuComponent subclass: #ErWelcomeComponent
>        instanceVariableNames: 'menu'
>        classVariableNames: ''
>        poolDictionaries: ''
> (ErMenuComponent was the parent for ErWelcomeComponent).
> However, I have set right all these problems and I am able to work
> with other parts of the application just fine.  It is only when I try
> saving a new user that the problem happens.

I am able to file out my package and then file in that to a pristine
image and get it working.  Thanks Markus, for your suggestions.

More information about the seaside mailing list