[Seaside] ShoreComponents broken on Squeak 3.9/3.10 and Seaside 2.8 ?

Stef Telford stef at ummon.com
Sun Sep 21 03:03:11 UTC 2008

Hash: SHA1

Stef Telford wrote:
> hey everyone, I don't know if this is the appropriate forum but, I
> figure it can't hurt to ask and hopefully someone has trode this
> path before (albeit off-list ;)
> I am curious to try and play with the shorecomponents under
> seaside. I have tried both under 3.9 and 3.10 (with loading updates
> as I go) and running seaside 2.8 (Seaside2.8a1-lr.563.mcz to be
> exact). Each and every time I access the demo pages (demo1-4) under
> seaside I get a nice debug message (pasted below). I installed
> ShoreComponents under 3.9 using package map and 3.10 using the
> Package Universe Browser.
> I take it from the error below that the
> ShoreRootComponent>>initializeApplication is not finding
> ShoreStandardStyles, etc. I take it this is due to a pretty
> fundamental change from seaside 2.6 -> 2.8 .. but .. other than
> running 2.6, has anyone else fixed this to work under seaside 2.8 ?
> I know this is pretty hit and miss, and thanks for getting this far
> :D Regards Stef
> MessageNotUnderstood: UndefinedObject>>default
> [] in WAApplication>>updateRoot: {[:each | each default updateRoot:
>  anHtmlRoot]} OrderedCollection>>do: WAApplication>>updateRoot:
> WASession>>updateRoot:
> WARenderContinuation(WASessionContinuation)>>updateRoot:
> WARenderContinuation>>newHtmlRoot
> WARenderContinuation>>processRendering: [] in
> WARenderContinuation>>render {[:response | self processRendering:
> response]} WARenderContinuation(WASessionContinuation)>>respond:
> WARenderContinuation>>render [] in WARenderContinuation>>run {[self
> render]} BlockContext>>on:do:
> WARenderContinuation>>withNotificationHandler:
> WARenderContinuation>>run WARenderLoop>>run [] in
> WARenderLoop>>call:withToolFrame: {[:cc | aComponent onAnswer: cc.
> self root: aComponent withToolFrame: aBool...]} AnswerContinuation
> class(Continuation class)>>currentDo:
> WARenderLoop>>call:withToolFrame: WAWalkbackErrorHandler>>open:
> WAWalkbackErrorHandler>>handleError:
Hey Everyone,
    Well, colour me stupid but, I was using the versions in the
package map/universal package loader. I fired up Monticello, added the
repository over at squeaksource, found the latest version
(ShoreComponents-3-pk.39.mcz), loaded it into the image and everything
worked fine. This is merely a 'placeholder' for anyone else that is
scratching their head and saying 'wtf' :)

seaside mailing list
seaside at lists.squeakfoundation.org

Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the seaside mailing list