[Seaside] Socket(Object)>>primitiveFailed

Germán Arduino garduino at gmail.com
Sun Aug 9 14:10:45 UTC 2009

Hi John:

The image is the same in both cases (a 3.10.2 that I use to develop. I
installed seaside and friends and a few dev tools packages).

The MAC vm is the version I mentioned (downloaded from your page I
think) and the Linux version is Squeak-3.10-6.i686-pc-linux-gnu.tar.gz
 (from http://www.squeakvm.org/unix/).


2009/8/8 John M McIntosh <johnmci at smalltalkconsulting.com>:
> Btw the Squeak 4.1.1beta2U.app and the Unix version of Squeak.app  use the
> same source code for the virtual machine
> Unix Socket support since both systems are Unix *like* operating systems, so
> you shouldn't find a difference in behaviour
> at the primitive layer.
> But given you get "Socket(Object)>>doesNotUnderstand:
> #waitForConnectionUntil:"
> where did the image & VM come from?
> On 8-Aug-09, at 9:36 AM, Germán Arduino wrote:
>> I'm using "Squeak 4.1.1beta2U.app" with a 3.10.2 image running on Mac
>> OS X Server 10.5.5. I tried on a linux box with a unix vm and get the
>> same error at socket level (Socket>>listenOn: /
>> TcpListener>>pvtOldListenLoop:)
> --
> ===========================================================================
> John M. McIntosh <johnmci at smalltalkconsulting.com>   Twitter:  squeaker68882
> Corporate Smalltalk Consulting Ltd.  http://www.smalltalkconsulting.com
> ===========================================================================
> _______________________________________________
> seaside mailing list
> seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

More information about the seaside mailing list