[Seaside] Seaside hangs - what can I do?

Matthias Berth matthias.berth at googlemail.com
Wed Jan 13 15:18:42 UTC 2010


I have encountered some error in a seaside image that lead to a
hanging request. Then I opened a process browser and terminated the
process that was associated to the request. Everything seemed to go
fine after that. However, now (after some more requests) the image is
not responding to any HTTP requests anymore. Everything else (browsing
code, inspecting) works OK. I have also tried other applications, e.g.
/seaside/config - not working.

I am using Pier, with some persistency that is subclassed from
PRImagePersistency. The process I terminated was in some semaphore
critical section (guess: when doing the persistency). I am working
from Pharo core 1.0rc1.

My guess is that there is some semaphore involved, and maybe some
process that is needed for handling http requests is no longer there.

Is there a way to "reset" everything so I get HTTP request handling
back? I have tried NetNameResolver initializeNetwork without success.

Is there anything that I can do to prevent situations like this in the
future? Anyone have a list of "do#s and don'ts " when using the
process browser?

Thanks a lot


More information about the seaside mailing list