[Seaside] call: works intermittently on Pharo

Larry White ljw1001 at gmail.com
Sat Sep 10 13:27:07 UTC 2011

Hi, I'm a newbie so apologies if I'm doing something dumb.

I'm working with Seaside in Pharo using the standard Seaside environment.

In my application, call: seems to work intermittently.  For example, I have
this method in one component:

| editor |

editor := ProductEditorComponent new.
(self call: editor)
ifTrue: [ Dao new addProduct: product ]

When I run my app, the method gets invoked (a halt statement is hit when I
add it to the method), but the ProductEditorComponent never renders and no
exception is raised.  I see this elsewhere in my app as well. On my login
form I have a link to a "forgot password" component that worked for a while
then stopped, also without raising an exception.

I'm assuming that what I'm doing wrong would be obvious to an experienced
Seasider since it seems to be easy to get into this state.  What causes a
component to fail to render when called without raising an error?

Thanks much for any assistance.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/seaside/attachments/20110910/f768afa1/attachment.htm

More information about the seaside mailing list