[Seaside] call: works intermittently on Pharo

Sebastian Sastre sebastian at flowingconcept.com
Sat Sep 10 14:45:14 UTC 2011

be sure you are sending #addProduct from a callback action like:

	html anchor
		callback:[self addProduct]
		with: 'Add this to cart'.



PD: be sure NOT to send #addProduct from a render kind of method

On Sep 10, 2011, at 10:27 AM, Larry White wrote:

> Hi, I'm a newbie so apologies if I'm doing something dumb.
> I'm working with Seaside in Pharo using the standard Seaside environment.
> In my application, call: seems to work intermittently.  For example, I have this method in one component:
> addProduct
> 	| editor |
> editor := ProductEditorComponent new.
> 	(self call: editor)
> 		ifTrue: [ Dao new addProduct: product ]
> When I run my app, the method gets invoked (a halt statement is hit when I add it to the method), but the ProductEditorComponent never renders and no exception is raised.  I see this elsewhere in my app as well. On my login form I have a link to a "forgot password" component that worked for a while then stopped, also without raising an exception. 
> I'm assuming that what I'm doing wrong would be obvious to an experienced Seasider since it seems to be easy to get into this state.  What causes a component to fail to render when called without raising an error?
> Thanks much for any assistance.
> Larry 
> _______________________________________________
> seaside mailing list
> seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/seaside/attachments/20110910/3396c606/attachment.htm

More information about the seaside mailing list