[Seaside] Is the community repository dead?

Sebastian Sastre sebastian at flowingconcept.com
Fri Feb 24 17:35:38 UTC 2012

Hi Nick,

I've tried many times and it failed every time. 

Gee... okay... I've tried now and it worked fine. So we're good again (so far and by now).

ss3 looks good enough. People says is more stable. I hope they're right.

I really liked what I saw in smalltalkhub but isn't available at the moment so we need something else.

The ultimate solution is to socialize all our smalltalk code in a reliable way and, to achieve that, the best idea so far I've heard of, is to extend Gofer to use git (or to somewhow have a git client for pharo).

That way any smalltalker could have its squeak/pharo code visible in social coding places (like github, etc). By the way, that counts a lot as part of a modern C.V./resumé so it's kind of stupid to stay out of it.

I don't really know how hard could be to make a git client for monticello packages but to get the basics running shouldn't be that hard. Once we have it we can integrate it to the monticello UI or something. Hey, just having it in Gofer alone will make all the difference.

Is anybody interested in this project? maybe ESUG or another organization interested in sponsoring such a project? I'm sure they will be held in high esteem because it would have high social value for our community.



On Feb 24, 2012, at 2:13 PM, Nick Ager wrote:

> Hi Sebastian,
> I was about to commit some packages under MIT in squeaksource but it seems that squeaksource.com is not allowing people to add projects anymore. When you click on "Register Project" instead of the usual form, it says "On this server, only the administrator can create new projects!"
> Is that expected now? If so, we did that not even telling people about that in a blog post suggesting what to do?
> I haven't heard that. Have you asked on the Pharo mailing list.
> Some told me to stop using it and start using ss3.gemstone.com instead. So I've registered my user and created a repo there but my commits are failing (timeout when trying to write)
> That's strange I've never had a problem with ss3. Have you tried it again? If the problem persists I'd suggest posting a bug on http://code.google.com/p/squeaksource3/issues/list
> Struggling with this will kill this community
> please help
> I'm sure you are aware that there are multiple initiatives to try to improve our VC/repository story (new version of SS3, smalltalkhub, experiments with using Git/GitHub etc)
> Nick
> _______________________________________________
> seaside mailing list
> seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/seaside/attachments/20120224/d156d4c5/attachment.htm

More information about the seaside mailing list