[Seaside] Trouble setting up Seaside daemon

muraiki eleison at muraiki.com
Fri Apr 26 15:25:25 UTC 2013

Hi all, I'm having some trouble setting up a Seaside daemon on a Linode
Ubuntu 12.04 host. I've run into two separate problems:

First, and I might just be doing something completely wrong here, but if I
try to run squeak with multiple command line arguments it fails. For

squeak -vm-display-null -vm-sound-null Seaside.image
found gettext in path
Could not open the Squeak image file `-vm-display-null'.

If I run "squeak -vm-display-null Seaside.image", though, it launches ok.

The other problem that I have is that when I try to use the supplied script
from the Seaside book, I get an error message. The script is on this page:

sudo ./run.sh
found gettext in path
chmod: changing permissions of `/home/(username)/.npsqueak/secure':
Operation not permitted

It seems like the problem lies with setuidgid, so this might not be the
right place to ask this question. I even tried running the command as root,
but I get the following error: "mkdir: cannot create directory `/root':
Permission denied" and I have no idea why a /root directory is trying to be

I would sincerely appreciate any help that anyone here can offer. Thank you!

View this message in context: http://forum.world.st/Trouble-setting-up-Seaside-daemon-tp4683810.html
Sent from the Seaside General mailing list archive at Nabble.com.

More information about the seaside mailing list