[Seaside] Trouble setting up Seaside daemon

Sven Van Caekenberghe sven at stfx.eu
Fri Apr 26 16:03:28 UTC 2013


On 26 Apr 2013, at 17:25, muraiki <eleison at muraiki.com> wrote:

> Hi all, I'm having some trouble setting up a Seaside daemon on a Linode
> Ubuntu 12.04 host. I've run into two separate problems:
> First, and I might just be doing something completely wrong here, but if I
> try to run squeak with multiple command line arguments it fails. For
> instance:
> squeak -vm-display-null -vm-sound-null Seaside.image
> found gettext in path
> /home/(username)/st/Seaside.app/Contents/Resources
> Could not open the Squeak image file `-vm-display-null'.
> If I run "squeak -vm-display-null Seaside.image", though, it launches ok.
> The other problem that I have is that when I try to use the supplied script
> from the Seaside book, I get an error message. The script is on this page:
> http://book.seaside.st/book/advanced/deployment/deployment-apache/run-vm
> sudo ./run.sh
> found gettext in path
> /srv/goldengate
> chmod: changing permissions of `/home/(username)/.npsqueak/secure':
> Operation not permitted
> It seems like the problem lies with setuidgid, so this might not be the
> right place to ask this question. I even tried running the command as root,
> but I get the following error: "mkdir: cannot create directory `/root':
> Permission denied" and I have no idea why a /root directory is trying to be
> created.
> I would sincerely appreciate any help that anyone here can offer. Thank you!
> --
> View this message in context: http://forum.world.st/Trouble-setting-up-Seaside-daemon-tp4683810.html
> Sent from the Seaside General mailing list archive at Nabble.com.
> _______________________________________________
> seaside mailing list
> seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

/usr/bin/squeak is actually a script that tries to do some fancy stuff, but it is often more an obstacle, IMHO. You could try to use the actually binary (read the script).

Since you are on Ubuntu, you could try installing the pharo VM using apt-get.

$ sudo add-apt-repository ppa:pharo/stable
$ sudo apt-get update
$ sudo apt-get install pharo-vm

Ask on the Pharo mailing lists if you have any problems.



Sven Van Caekenberghe
Proudly supporting Pharo

More information about the seaside mailing list