[Seaside] Loading Seaside 3.03 into Squeak 4.4

Tobias Pape Das.Linux at gmx.de
Fri Aug 23 09:22:51 UTC 2013

Am 22.08.2013 um 20:19 schrieb "jtuchel at objektfabrik.de" <jtuchel at objektfabrik.de>:

> Hi Tobias,
> first of all, thanks for your time and help!
> Am 22.08.13 16:01, schrieb Tobias Pape:
>> Am 22.08.2013 um 15:46 schrieb "jtuchel at objektfabrik.de" <jtuchel at objektfabrik.de>:
>>> Hi,
>>> I just tried to install Seaside 3.0.3 into a freshly downloaded Squeak 4.4 all-in-one image using the SqueakMap Package Loader.
>>> The result is an exception during download/installation:
>>> Could not access http://ss3.gemstone.com/ss/Grease
>>> I think the url should be changed to http://ss3.gemstone.com/ss/grease (note the difference between Grease and grease), at least that url can be accessed from a web browser while Grease can't.
>>> What has to be changed where? Who can submit it where it belongs to?
>> In Fact, it should be http://ss3.gemtalksystems.com/ss/grease, not http://ss3.gemstone.com/ss/grease.
> thanks. I hope I can change that somewhere.
> BTW: is the 4.4 distribution at squeak.org current? Is there a newer distro? I can hardly believe I am the first to encounter this problem.
> OTOH, Why do you want to install an outdated version of Seaside?
> Well, beacuse it is the newest that is present in the SqueakMap Catalog in the latest Squeak 4.4 image as I have downloaded it today from Squeak.org.
> If there is a newer one that I can load into Squeak without first studying ConfigurationOf..., Gofer, Meta- and MOnticello first, I prefer to load a newer one. Especially if it can be loaded easier.

It should, however things are fragile at the moment due to a lot of independent components involved
are currently moving.
Monticello has a HTTP problem (I think I really should fix that).
Metacello is in a transitional state as the scripting api is to be finalized soon.
Seaside is being prepared for 3.1 and so Configurations are being worked on.
A lot of project are migrating repositories.

long story short, I cannot guarantee that either the squeakmap entry or the metacello
config are working, but we are short on staff recently :)

I also hope that we find time to put a seaside job on http://build.squeak.org/

>> The current is 3.0.8, an All-in-one image is also available
>> from the ftp.
> which ftp? Seaside? Squeak? Can you provide a link?
> Please allow me a little comment on this topic.
> I've been trying to dive into Squeak or Pharo several times over the last few years. Literally every single time I started over, I had problems like this.
> All I wanted was a Squeak or Pharo Image with both Seaside and Magma loaded. My first attempt was with Squeak 3.9, and it was the last time I could load both into one image without any problems. Most of the times when I asked for help with this, I was offered some premade-Image with one or both of them in it. But that is not good enough. I need reproducible artefacts if I want to use code for a system that I want to work - commercially or not.

You raise an important topic. I would say, we are aware that jumpstarting Squeak, or Seaside on Squeak
is currently not really obvious nor easy. 

That being said, I am curious, what your expected experience would be :)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 203 bytes
Desc: Message signed with OpenPGP using GPGMail
Url : http://lists.squeakfoundation.org/pipermail/seaside/attachments/20130823/7e612d44/signature.pgp

More information about the seaside mailing list