[Seaside] Pharo 2.0 scriptaculous does not work

Johan Brichau johan at inceptive.be
Fri Jun 7 07:56:41 UTC 2013

Hi Sven,

On 07 Jun 2013, at 09:37, Sven Van Caekenberghe <sven at stfx.eu> wrote:

> Now, ConfigurationOfZincHTTPComponents does _not_ specify which version of Zinc-Seaside should be loaded. It is not even in the config. It is Seaside that depends on Zinc and the adaptor, the other way around in not possible. It seems that somehow, the latest Zinc was loaded and not the latest adaptor, which matches it.

Seaside depends on the #stable version of Zinc but if Zinc upgrades its #stable version, the Seaside config should also upgrade its matching version of Zinc-Seaside.
Therefore, it seems natural that Zinc specifies the Zinc-Seaside version number that matches the Zinc version (as you say).

In earlier versions of Zinc, the Zinc-Seaside package was mentioned (version 1.0 and 1.1).

Or we adapt the Seaside config to depend on a specific Zinc version (which is less optimal imho)

What do you think?

More information about the seaside mailing list