[Seaside] Seaside Error - No Secure Generator Available

mldavis at chaparralwest.com mldavis at chaparralwest.com
Thu Jun 30 17:34:16 UTC 2016



Many thanks.  I would never have figured this out.


It worked exactly as you said, in all my images.  Some of these are on
different machines and yet, they all suddenly started with this same error,
all the same day????  At least two of these have been running for over a
week without the error (starting, stopping, making changes etc).  I wonder
what triggered it..


Anyway thank you so much:  It was in Seaside 3.2 loaded into Pharo 5 build
50760 running on Zinc server on Windows 10 latest stable.






From: David Pennington [mailto:lhdavid at me.com] 
Sent: Thursday, June 30, 2016 9:21 AM
To: mldavis at chaparralwest.com; Seaside - general discussion
<seaside at lists.squeakfoundation.org>
Subject: Re: [Seaside] Seaside Error - No Secure Generator Available


I had this problem when running seaside in my VAST Smalltalk image. I was
advised as follows by Instantiations:


I can reproduce this.

Looks like Seaside wants to generate random numbers to use as keys for
session caches.  If a secure RNG (via OpenSSL) is not available in Vast then
it produces this walkback...even for http.
If it's not found at startup, then it installs a
'WANoSecureKeyGeneratorAvailable' which produces an error when asked for a


To get around this, try changing the key generator method to the following
below.  This will force it to fallback to using EsRandom as the RNG.
In the meantime, we will revisit this internally to see if we can disconnect
the OpenSSL requirement from the session cache keys.

Thanks for bringing this up....please let me know if the change described
below solves your issue.


WANoSecureKeyGeneratorAvailable>>keyOfLength: anInteger

            ^super keyOfLength: anInteger


Long Haired David

A.K.A. David Pennington

lhdavid at icloud.com <mailto:lhdavid at icloud.com> 




On 30 Jun 2016, at 15:33, mldavis at chaparralwest.com
<mailto:mldavis at chaparralwest.com>  wrote:


Seaside 3.1 & 3.2 running on Windows 10 


Since yesterday, all of my images of Seaside on two different machines are
getting this error when I connect to them from  <http://localhost:8080/>
http://localhost:8080 :


Seaside Walkback



WAError: no secure key generator availble because seeding failed

Debug Full Stack


Stack Trace


WANoSecureKeyGeneratorAvailable class(GRObject class)>>error:






a WANoSecureKeyGeneratorAvailable




a WANoSecureKeyGeneratorAvailable




a WAHashCache


[ cache store: anObject ] in WAMutualExclusionCache>>store:


a WAMutualExclusionCache



The multi image & different machine impact makes me wonder if this was
caused by a Windows 10 update, which come without warning now?


Can anyone help me?


Thanks, mike



gn=sig-email&utm_content=emailclient&utm_term=link> www.avast.com

seaside mailing list
 <mailto:seaside at lists.squeakfoundation.org>
seaside at lists.squeakfoundation.org


This email has been checked for viruses by Avast antivirus software.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/seaside/attachments/20160630/ebf1ae18/attachment.htm

More information about the seaside mailing list