[Seaside] Seaside and Pharo 6: Problem with Umlauts?

Johan Brichau johan at inceptive.be
Fri Jun 9 17:37:10 UTC 2017

Hi Dietmar,

Regarding Seaside 3.2 on Pharo 6: You were just ahead of me today. 
There was no stable version of Seaside 3.2 that worked on Pharo 6, until now.
If you reload the stable version, you should get a working version.
(There was ongoing work for Seaside 3.3 that included Pharo 6 fixes, but it was not finished yet.)

Regadering the changes you had to make and the problems with umlauts: I cannot reproduce them.
I suspect there is something you do in your Seaside app that changes the Stream class that is used to render.
Which Seaside version did your app work well on?


> On 9 Jun 2017, at 16:35, Dietmar Schielke <dietmar.schielke at data-experts.de> wrote:
> Hello Seasiders, 
> I just managed to load Seaside  into a Pharo 6.0 image running on MacOS Sierra unsing 
> Metacello new 
>   configuration:'Seaside3'; 
>   repository: 'http://www.smalltalkhub.com/mc/Seaside/MetacelloConfigurations/main'; 
>   version: #stable; 
>   load. 
> Beside starting the ServerAdaptor manually via 
>         ZnZincServerAdaptor startOn: 8081. 
> because of the missing class NewListModel 
> I had to change 
>         WAResponse>>writeStatusOn: 
> because the used stream does not support 
>         #nextPutAll: with a Character as argument. 
> So I changeed in #writeAStatusOn: 
>         nextPut: $ ; 
> to 
>         nextPut: $  charCode; 
> in two places. 
> Furthermore the used stream does not support 
>         #crlf 
> so I added it to ZdcAbstractSocketStream. 
> Now I can open the examples etc. 
> That was easy :-) 
> Now I tried to deploy an old Seaside App written by me and got "cannot parse response" error in my webbrowser (no debugger in the VM). 
> I tracked it down to the use of Umlauts (äüö) in the rendered pages. 
> As a simple demo of this problem I changed the WACounter example. If I add a german Umlaut to the "++" or "--" label I get a "cannot parse response" in my browser upon rendering the WACounter expample. 
> Is there something wrong with my setup or is it a bug? 
> Many thanks for any hints. 
> Happy coding, 
> Dietmar 
> _______________________________________________
> seaside mailing list
> seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/seaside/attachments/20170609/7f794b52/attachment.html>

More information about the seaside mailing list