[Seaside] How to reset everything in Seaside

Sven Van Caekenberghe sven at stfx.eu
Wed May 24 05:34:16 UTC 2017

> On 24 May 2017, at 03:18, Tim Mackinnon <tim at testit.works> wrote:
> Hi - I’ve tried loading the latest seaside 3 stable into pharo 6. It seemed to work ok, although the control panel doesn’t work - so I tried ZnZincServerAdaptor startOn: 8080. And then was able to use a web browser.
> So far so good - however in the reddit booklet, I got to the bit where I need to configure my web app, so I went to the browser and found the page where I thought you did this - picked add - typed reddit and selected the RedditSession and then it all went wrong and I was getting a walkback about some parent class not understanding something (sorry I’ve lost the error now). I fiddled a bit more and then now I’m stuck with "Error: you are forbidden to access "/"  
> So my question is - how do I reset everything?


  WAAdmin clearAll

Else throw away the image ;-)

> And then, does Seaside work in Pharo 6 yet?

Of course.

> Hopefully someone can point me in the right direction as it was going quite well up to this point.

You don't have to configure anything using those tools.

A bit further it says: "To install a Seaside application, a class side initialize method is typically used." Then the installation happens automagically.

Note that the tutorial is not really a step by step guide like the MOOC. It shows an implementation in '10 cool classes', which confuses the order a bit I guess.



> Tim
> _______________________________________________
> seaside mailing list
> seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

More information about the seaside mailing list