<div dir="ltr"><div>Hi all,</div><div><br></div><div>From some time now, I want to have a consistent naming criteria for the selectors that return a JSObject or a JSFunction, and I'd like to know other ideas about naming them.</div><div><br></div><div>I name all the HTML rendering methods with the `renderSomething...On:`, so "render" is always the prefix and the canvas (html) the last argument (being it a single argument, or more than one).</div><div><br></div><div>And because of that I don't want to use 'render' as a prefix for the methods that create a script.</div><div>So lately I'm using the "create...On:" pattern for these selectors.</div><div><br></div><div>E.g. when you have something like:</div><div><br></div><div>renderContentOn: html</div><div>   html anchor<br></div><div>      onClick: (self createClickScriptOn: html);</div><div>      with: 'Click to toggle'.</div><div><br></div><div>createClickScriptOn: html<br></div><div>    ^(html jQuery id: 'foo') toggle</div><div><br></div><div><br></div><div>What is your criteria, if any, for this?</div><div><br></div><div>Regards!</div><div><br></div><div><div class="gmail_signature">Esteban A. Maringolo</div></div>
</div>