Unix sound bug not fixed in 2.3 beta.

Lex Spoon lex at cc.gatech.edu
Wed Dec 2 21:13:17 UTC 1998

I'm not sure why, but synchronous support hasn't worked for a few versions now, and I'm not planning to fix it.  The page actually says this, but a lot of people don't notice.  (I just fixed the page to be a little more explicit; the update will take effect at 6am tomorrow).

Anyway, try it with asyncronous support and see if THAT works....  And be sure to turn UseReadySemaphore back to 'true'.

Happy Squeaking,


Bill Cattey <wdc at MIT.EDU> wrote:
> I think I may have made a mistake, or mis-understood how to apply them.
> I was unable to get them to work.  Mind you, I am attempting the
> SYNCHRONOUS support.  All I get is a "click" from my speaker, and then a
> hang.
> I've confirmed that I did do:
> #define HAS_OSS_AUDIO
> (At one point I put it in the sqUnixSound.c file just before the #ifdef,
> just to be sure.)
> When I got the same behavior, I Changed the assignment to
>      UseReadySemaphore to be false instead of true. 
> When that still resulted in the same behavior, I tried changing the
> first line of SoundPlayer>>startPlayingImmediately to:
>         dontInsertSamples _ true.
> Always the same, click and a hang.
> -wdc

More information about the Squeak-dev mailing list