Lost mouse clicks

Karl M. Mo karl.mo at c2i.net
Mon Jun 14 21:33:44 UTC 1999

I am using Windows98, no service packs.
Up until recently I used a 3-button Logitech Trackman with the newest
available driver from the Logitech web site. I now use a Microsoft mouse
with the default driver that Win98 installs when it detects it.
The processor is an AMD-K6 3D 330 MHz on a Via VA-503+ motherboard with 64
And yes, I have tried changing "Use 3 button mouse mapping" and "Reduce CPU
usage" - and "Defer display update" for that matter.
I am running a Squeak.exe with file date 99.04.22, which reports VM version
as 1998/10/02, image and change file are version 2.4c.
But, since I wrote the mail I have twice had failed boots on the
machine -blue screen with message text "failed loading driver xxx.vxd" or
something similar.
It is not stable, but something may well be messed up on my hard disk .
I also have a number of apps and utilities installed on the machine, at
least one of them replaces a Windows dll with the version that was current
when the app was released, others may also have done unconventional things
to the Windows configuration.
I discarded searching down that route since other Windows apps did not have
the same problem, but can see that that reasoning may be dubious since
Squeak uses a different polling mechanism.
I will check the hard disk, reinstall Windows and let you know if that
solved it.
    regards Karl

----- Original Message -----
From: Dwight Hughes <dwighth at ipa.net>
To: Karl M. Mo <karl.mo at c2i.net>
Sent: 11. juni 1999 05:19
Subject: Re: Lost mouse clicks

> Is this under Win95, Win98, or WinNT? What service packs are loaded? Are
> you using the default Microsoft mouse drivers or do you have special
> mouse drivers? What is your processor speed, processor type, and amount
> of RAM? Have you tried toggling "Reduce CPU Usage" (hit F2 to get the VM
> Preferences menu)? Do you have a three button or two button mouse? Have
> you tried toggling the "Use 3 button mouse mapping" in the VM
> Preferences menu? What version of Squeak are you using? Are you sure you
> are using the matching VM version? I've never had this problem under
> Windows and haven't heard of others having it - which is why all the
> questions.
> -- Dwight
> "Karl M. Mo" wrote:
> >
> > When using Squeak under Windows, I find that many (most) times Squeak
> > doesn't recognize
> > that a mouse key has been clicked.
> > The only way around it I have found is to hold the mouse key down for a
> > short period, instead of
> > releasing it immediately - but I find that irritating, and forget to do
> > all the time.
> > This is not a problem in other Windows applications on the same machine,
> > from previous
> > postings to the list I suspect it happens because of the way the base
> > classes polls
> > for events.
> > Changing the VM preferences or working in Morphic instead of MVC
> > does not help.
> > Does anybody know of anything I can change to improve this ?
> >     regards Karl

More information about the Squeak-dev mailing list