doIfNotNil: -- let's bake the other half
squeak at wattle.net
Mon Oct 16 04:47:24 UTC 2000
When I read and write code, I think in terms of actions and activity.
The words we use are activity oriented: assign, loop, call, select
Also, I'd go for ifNotNilDo: because, as I read a line from left to
right, it 'reads' better to me: 'variable ifNotNilDo: [ a block ]' -
'ifNotNil' refers to the variable and 'Do:' refers to the block.
More information about the Squeak-dev