[PROBLEM] A question about installing Squeak2.8 on Linux

William J. DeMeo william.demeo at verizon.net
Wed Jan 10 11:18:46 UTC 2001

Here's some excerpts of an older thread concerning the same problem.  

Original message header
Subject: Squeak 2.8 Linux install problem
Resent-Date: 9 Dec 2000 22:58:17 -0000
Resent-From: squeak at cs.uiuc.edu
Date: Sat, 09 Dec 2000 17:58:22 -0500
From: David Relson <relson at osagesoftware.com>

Original message
David Relson wrote:
> Greetings,
> I'm attempting to install Squeak on my Linux box.  I'm using
> ftp://st.cs.uiuc.edu/pub/Smalltalk/Squeak/2.8 as my data source.
> As my first shot, I downloaded all the Squeak*2.8*rpm files.  The install
> fails (see below) due to a missing file - which is not on the ftp site.
>      [root at osage Squeak]# rpm -ivh Squeak-2.8-3.i386.rpm
> Squeak-image-2.8-3.noarch.rpm
>      error: failed dependencies:
>              Squeak-sources is needed by Squeak-2.8-3
> For my second shot, I figured to use tarballs.  However
> Squeak-2-sources.tar.gz appears to be corrupt:
>      [root at osage Squeak]# ls -l Squeak-2-sources.tar.gz
>      -rw-r--r--    1 root     root      1361812 Dec  9 17:26
> Squeak-2-sources.tar.gz
>      [root at osage Squeak]# sum Squeak-2-sources.tar.gz
>      08348  1330
>      [root at osage Squeak]# tar ztvf Squeak-2-sources.tar.gz
>      tar: This does not look like a tar archive
>      tar: Skipping to next header
>      tar: 163 garbage bytes ignored at end of archive
>      tar: Error exit delayed from previous errors
> Can someone please point me towards a better source for Squeak?
> Thank you.
> David

First reply
If I remember correctly from my install experience, the sources file is
misnamed.  It is not a tar archive, it is just a compressed file.  Just
uncompress the file and rename it to SqueakV2.sources.


Second reply
Yes.  Same was true for me (ie the file is misnamed).  I suppose one
could rename the file to one with no extension and use the "file"
command on the new name to see what it is.

Third reply
Thanks for the info that Squeak-2-sources.tar.gz is the needed source
merely misnamed.  Guess I'll have to download all the tarballs since the 
rpm system isn't willing to believe that I don't need the sources.rpm it


Fourth reply
rpm has some options for forcing an install when you are certain that
the stated dependencies are not really necessary.  I think the option is
-f but look at the man page to be sure.  But you're probably better off
installing from source anyway.

Fifth reply
I tried the --force option and rpm was still unwilling to install the 
package.  Rereading the man page, it seems that --force may only apply
forcing upgrades (as compared to forcing an install).  Come to think of
it might be possible to install 2.7 and upgrade ...  Probably not worth 
it.  I'm gonna go the tarball route.

Sixth reply
You should use --nodeps in order to ignore dependencies.


Final reply
Try the 2.7 rpms - worked a treat for me under Mandrake 7.x using


More information about the Squeak-dev mailing list